Archive
 
 
  Topic: keying of CQ100 with Keyer Software (9 replies)
#1     Tue Jan 29, 2008 7:10 pm
VE9AAS
Saint John
 
Join Date: Nov 2006
Posts: 6
Subject: keying of CQ100 with Keyer Software

There may be many who already know this, but here is what I discovered recently: CQ100 can be keyed directly from a software based Keyer program.

During a search for PC based keyer software that can be connected to paddles or a straight key, I found one program worth mentioning for two reasons - (1) It is a great memory keyer that can be used to key your HF rig by connecting your key to the Serial port or game port and (2) it can be used to directly key the CQ100 program - WITHOUT any external connection such as sounder which is in one way or other connected to the microphone input of your PC to produce the audio portion of CW. The output sounds pretty smooth and lacking any teat equipment, I suspect the audio output of the keyer is somewhat close to a sinewave.

The name of the program is EhoCW which is free and can be downloaded at http://www.f8eho.net/eng/. I am in no way affiliated with this program or its creater - I am simply a discoverer of the program after an internet search. I simply want to share my findings with you

What is required is to simply start both programs (EhoCW and CQ100) Set the audio level so that CQ100's S meter reads as described in its op instructions and key to your heart's content. Of course the mode switch on CQ100 has to be set properly as well.

There are those that use the VOX option when keying via mic audio and we have heard over and over again what can and will take place if you neglect to switch back off of the VOX mode. With the EhoCQ/CQ100 setup, if you happen to forget to switch off VOX, I don't believe any harm will be done because there is no microphone in operation.

Reports that I have had from my qso's over the past few days are in general - "great signal" which equates to 5NN
__________________
#2     Mon Feb 25, 2008 9:37 pm
W4QO
Roswell, GA
 
Join Date: May 2007
Posts: 2
Subject: EhoCW

I tried the EhoCW program with CQ100 and got no reaction from CQ100 when I tried to keyboard the EhoCW.

You said - be sure CQ100 is set in the correct mode. Do you mean CW? Any other mode would use the microphone yet you say the microphone is not involved.

Do you have to set the EhoCW output mode to something other than the default?

Thanks.

jim/w4qo
__________________
#3     Tue Feb 26, 2008 7:35 am
KB3NPH
Spring Run, PA
 
Join Date: Mar 2007
Posts: 52
Subject: Re: EhoCW


W4QO wrote:
I tried the EhoCW program with CQ100 and got no reaction from CQ100 when I tried to keyboard the EhoCW.

You said - be sure CQ100 is set in the correct mode. Do you mean CW? Any other mode would use the microphone yet you say the microphone is not involved.

Do you have to set the EhoCW output mode to something other than the default?

Thanks.

jim/w4qo


Hi Jim,
For any of the digital modes you must go into your sound card setup and select STEREO MIX, WAVE MIX, OR SIMILAR SETTING AND THE MIC BECOMES DISABLED.

HOPE THIS HELPS
TIM, (KB3NPH)
__________________
#4     Sat Mar 14, 2009 5:15 pm
GW4ALG
Chepstow
 
Join Date: Mar 2007
Posts: 9
Subject:

Your advice certainly helped me! - which means that I've _almost_ now got the keyboard side of EhoCW working fine with CQ100.

But here is a strange thing.... When I set the audio level in the VOX mode using the Stereo Mix slider (say, to 'S9' on the scale), and then click the CQ100 MODE button five times (to cycle it back to 'VOX') - the audio level now end-stops on the scale. It's as though hitting the MODE switch is causing the level to revert to a default setting. So I then need to re-adjust the slider to get the level set again.

Is this expected behaviour? Does it matter?

73, Steve.
__________________
#5     Mon Mar 16, 2009 7:17 am
KB3NPH
Spring Run, PA
 
Join Date: Mar 2007
Posts: 52
Subject:


GW4ALG wrote:
Your advice certainly helped me! - which means that I've _almost_ now got the keyboard side of EhoCW working fine with CQ100.

But here is a strange thing.... When I set the audio level in the VOX mode using the Stereo Mix slider (say, to 'S9' on the scale), and then click the CQ100 MODE button five times (to cycle it back to 'VOX') - the audio level now end-stops on the scale. It's as though hitting the MODE switch is causing the level to revert to a default setting. So I then need to re-adjust the slider to get the level set again.

Is this expected behaviour? Does it matter?

73, Steve.


Hi Steve,
One of the things you want to watch is with CQ-100 in the mode to do the digital stuff, you set the AF level control on C-100 to around the 9:00 position. You can re-adjust the s-level by using the AF control on the front of the radio display. Hope this helps.

If you need more help, goto my website www.kb3nph.com. There is a video on there to set up CQ-100 and the audio. Quality isn't too good, but you can get the idea from there. Trying to find a better screen recorder program that will give me better quality when I make my next video.

73s
Tim (KB3NPH)
__________________
#6     Mon Mar 16, 2009 11:46 am
GW4ALG
Chepstow
 
Join Date: Mar 2007
Posts: 9
Subject: Setting the CQ100 audio levels

Thanks, Tim

Most helpful. I had been making way too many assumptions.

I'll explain these below in case others have been having trouble too! (I note that at least one person on this discussion group got very frustrated by the whole process!)

This is what I think I know about the audio input settings on my PC when using a built in tone generating program (such as EhoCW) that routes the audio internally:
1) the CQ100 MIC GAIN control has no effect;
(this came as a bit of surprise to me because I had assumed that it was an input level control)
2) the CQ100 AF GAIN control sets the VOIP drive level from the tone source;
(this also came as a surprise to me because I had assumed that it set the level to the PC speakers - a bit like an AF GAIN control on a receiver)
3) the 'Audio Input' and 'Audio Output' volume settings behind the white CQ100 '?' symbol are not 'sticky': that is, the Stereo Mix (Audio Input) and Wave (Audio Output) volume settings are not stored;
(which probably explains why the VOIP drive signal kept resetting each time I touched the MODE switch).

The upshot is that, for the time being, I am:
a) making sure that the Stereo Mix option is selected;
b) ignoring the CQ100 Audio Input Stereo Mix volume setting;
c) ignoring the CQ100 Audio Output Wave volume setting;
d) setting the VOIP drive level using the CQ100 AF GAIN control (to 9 o'clock on the knob which, on my sound card, corresponds to about S9 on the meter);
e) setting the CW sidetone level using the gain control on the PC speakers.

If I am doing anything really silly, hopefully the above information will highlight where I'm going wrong. But it seems to work for me.

73, Steve
__________________
#7     Mon Mar 16, 2009 5:14 pm
GW4ALG
Chepstow
 
Join Date: Mar 2007
Posts: 9
Subject: EhoCW and CW Communicator

An Update.

Although the tone from EhoCW sounds fine when sending from the keyboard and when sending 'canned' messages, I find that the tone generated by EhoCW when using the serial port is very clicky (both for paddle and for straight key operation).

So I've just tried another program called 'CW Communicator' which generates morse with no key clicks at all - in fact it might even be a little too soft!

I hope this helps.

73, Steve
__________________
#8     Tue Mar 17, 2009 6:28 am
KB3NPH
Spring Run, PA
 
Join Date: Mar 2007
Posts: 52
Subject: Re: EhoCW and CW Communicator


GW4ALG wrote:
An Update.

Although the tone from EhoCW sounds fine when sending from the keyboard and when sending 'canned' messages, I find that the tone generated by EhoCW when using the serial port is very clicky (both for paddle and for straight key operation).

So I've just tried another program called 'CW Communicator' which generates morse with no key clicks at all - in fact it might even be a little too soft!

I hope this helps.

73, Steve


Hi Steve,
Something I have found with CW on CQ-100 is if my speaker volume is too high, the sound is very "clicky", both on receiving and sending. It sounds like you can actually hear the key tapping so to speak. When I turn my audio down considerably, I lose those extra sounds and the tone sounds pure. Could be just my sound card, but give that a shot and see if it helps.

73s
Tim (KB3NPH)
__________________
#9     Tue Mar 17, 2009 8:09 am
GW4ALG
Chepstow
 
Join Date: Mar 2007
Posts: 9
Subject:

Thanks, Tim

Yes, I did try altering the levels and it made no difference with my hardware.

The comparison is so marked that it's as though EhoCW employs waveform shaping for keyboarding and canned messages, but that the waveform shaping gets bypassed when the software acts upon manual keying via the serial port.

73, Steve
__________________
#10     Sat Jan 30, 2010 5:48 pm
VE9AAS
Saint John
 
Join Date: Nov 2006
Posts: 6
Subject: connecting cq100/ehocw on windows 7 64 bit

Does anyone know what the settings would be for the audio of these two pgms running on a win 7 (64bit) machine? I had to run ehocw in winxp sp2 mode to get it to load up without the "this program needs true 32 bit system" error. It will not send the keyer audio to cq100 nor will cq100 send its cw received audio back to ehocw to work the decoder function. I cannot find the stereo mix function (if there is one in WIn 7) mentioned in a previous post.
I sure would like to be able to use these two programs again.
__________________




Copyright ©2013 Cormac Technologies Inc.