Archive
 
 
  Topic: Am forced to log into Windows as administrator to use CQ100 (1 replies)
#1     Fri Jul 11, 2008 1:02 am
N7TXH
Prescott, AZ DM34SO
 
Join Date: Jul 2008
Posts: 1
Subject: Am forced to log into Windows as administrator to use CQ100

I use a separate administrator account and a separate user account on my Windows XP computer. That is probably more typical of how a computer in a business would be set up than how a home computer would be set up, but many users such as myself do that for the added security that it provides.

I am able to use the CQ100 program when I am logged into Windows XP as administrator, but not when I am logged in under my ordinary user name of Rick. When logged into Windows as Rick, I click on the CQ100 icon and it asks me for my password. When I give it my password and click the button, it says: "No call sign, please reinstall the program." When I am logged into Windows as administrator, I don't have that problem and am able to successfully run CQ100.

I have tried to reinstall the program when logged in as Rick, but got an error message saying that I didn't have the required privileges to continue the installation. So I logged out of Windows and logged back in as administrator and then reinstalled CQ100. Afterwards the results were the same, the program would work when I was logged in as administrator but not when logged in as Rick.

Can I get CQ100 to work when I am using my Windows computer and logged in as Rick? I would have preferred to run the program under WINE on my Linux computer (which is my main computer), but from what I have read in other posts, CQ100 does not run very well under Linux.
__________________
#2     Fri Jul 11, 2008 10:02 am
VE3EFC
 
Join Date: Aug 2006
Posts: 724
Subject:

Hi Rick. Thanks for telling me about this problem. You are the first one in 2 years to report this. I guess most Windows people have install privileges.

We write the registry keys for the current user, so in theory many users can be installed onto one machine. I see the problem if you install as admin then switch to another user, there are no registry keys for that user. That user can install again which creates his private registry keys. The problem happens if this user does not have permission to install stuff, the installer fails.

I think the answer is to code CQ100 so it will create the registry keys if they are missing for the current user. This includes a dialog to ask callsign. I will put this on the todo list for next version.

In the meantime, the problem is solved if the current user is given install permissions.
__________________




Copyright ©2013 Cormac Technologies Inc.